Stupid resource pack editor deleted my files!

Ok so I was using the old editor before I got an account and me and my brother had several packs that were not saved onto my computer. Then, out of the blue, all of them are gone!!! Please help!!!

This is extremely frustrating as I have been working hard on them.

um i cant help but this might help but you might have to be on a profile to save it plz reply alrite back to sleep :zzz:

Have you never exported the zip file once? You can re-import them.
The resource pack files are saved locally on your browser, they are not saved online. I recommend you to use the dropbox integration.

When was the last time you had accessed the files on the old editor?

The day before and yes I know I can download and re import files. I hadn’t exported some of them, including my brothers.

I used the old editor all the time actually.

The problem is that the old editor was using an “temporary” file system storage, and the browser can erase this storage when it needs space for other things.
The new version uses a persistent storage and this problem does not occur anymore.

There is a specific reason why you were using the old editor?

I liked it better and I was used to it. Thanks for telling me that! Ill make sure to use the new editor from now on!

something like that happened to me but i had an account and inported a texture pack but now half of the files of the texture pack are gone (it was a texture pack for 1.7 and higher)

I TRIED TO RE SAVE THE FILES BUT IT AUTO DELETET THEM

is there some sort of max of how many files you can have in a texture pack???
cause thats stupid
and say that when i save it cause it says nothing and acts like it put the file inside of the recource pack and worked BUT I DIDNT, WHY DOESNT IT SAY LIKE: ‘you cannot put anymore files in your texture pack’ WHY NOT EVEN SOMETHING LIKE THAT!!!
:confounded: :sleepy: :worried:

The same thing happened to me, and all was fine until I tried to download the resource editor onto my computer (you know, the button that says “my computer”).

So, I had originally created a couple of little packs. Nothing strange. They disappeared, but I just made some new ones. Now, these new ones are the ones I want. When I clicked the button to download the resource thing onto my computer, it reverted my packs back to before I had any I really wanted. Is there any way I can access these files again? I’m using Google Chrome, if it helps.

You can try this extension, install it, open the resource pack editor page, and open the extension from the red button

Maybe your files are under the temporary/persistent storage.
If there is something there you can explorer and save some files.