Home Skin editor Wallpapers Resource Packs

Won't Let Me Use Gallery Textures, Download Doesn't Work?

I went on the gallery to see if I could make a new resource pack, and when I tried to put a texture on, it tells me I need to install the actual pack first. Normal, right? After downloading and installing, the page went to verify it, but it says I need to download and install AGAIN.
So I did, about 10-12 times more, and decided there’s something wrong. Of course. It says I’ve downloaded and installed, but every single time I try to put on a texture, it says I need to download the pack again! I just joined Nova Skin, but I can’t even use the gallery or the resource pack. All I can do is use the skins for the player.

Can anyone help?

This has happened to me too, I do not know how to fix it, It’s worked a few times in the past but, Not anymore?

i cant even use the gallery to add the skins for the mobs and i have the nova skin resoure
pack installed

Jual is my jam 12 monster school kamu nya plz give me serizah craft 411 herobrine girl skin
let’ me well hungry i’am sorry skin @Katie_Barber